What's new
iamretro

Wow! It seems you have yet to create an account with us! Needless to say, you have to register in order to get the full "iamretro" experience! You will then be able to create your own topics, reply to posts and be an active member of the MOST prolific community in Greece (even further than that, but we're being modest for now). So don't delay! REGISTER!

Προβληματικό Commodore Disk Drive 1541

Pablo Sanchez

Retro Member
Comrade
Joined
Aug 31, 2017
Messages
125
Καλημέρα σας, βρέθηκε στα χέρια μου πριν από λίγους μήνες ένα drive commodore 1541, το οποίο εξωτερικά είναι σε καλή κατάσταση, και εσωτερικά θα έλεγα είναι μια χαρά.

Το πρόβλημα είναι ότι όταν κάνω:

Code:
LOAD "$",8

δεν λαμβάνω απάντηση ποτέ, εμφανίζεται συνέχεια το μήνυμα:

Code:
SEARCHING FOR $

Από την έρευνα μου δοκίμασα τα εξής:
  • Αντικατάσταση IC 74LS06 (έβαλα socket και ένα SN7406N σαν αντικαταστάτη)
  • Δοκιμή με piggyback αντικατάστασης του 74LS14
  • Αντικατάσταση των 2 6522
  • Αντικατάσταση του 6502
  • Δοκιμή του unit με ένα δεύτερο C64
Αλλά χωρίς κανένα αποτέλεσμα. Το μόνο που κάνει όταν ανάβει είναι να περιστρέφει το μοτέρ για 2 δεύτερα, ανάβει μία φορά το κόκκινο led και το πράσινο led παραμένει αναμένο.

Άλλο που σκέφτηκα είναι το σειριακό καλώδιο, που κατασκεύασα μόνος μου, αλλά από ότι είδα είναι οκ, όλα τα pins τα μέτρησα και έχουν continuity.

Σας αφήνω μερικές φωτογραφίες και αναζητώ τη βοήθειά σας.

Ευχαριστώ!
 

Attachments

  • IMG_20200228_211031.jpg
    IMG_20200228_211031.jpg
    1.6 MB · Views: 6
  • IMG_20200228_211040.jpg
    IMG_20200228_211040.jpg
    1.7 MB · Views: 6
  • IMG_20200228_211133.jpg
    IMG_20200228_211133.jpg
    1.3 MB · Views: 6
  • IMG_20200228_211146.jpg
    IMG_20200228_211146.jpg
    670.8 KB · Views: 6
Last edited:

Pluto63

Retro Addict
Comrade
Joined
Oct 14, 2014
Messages
787
Το piggyback στα LS δεν δουλεύει αν ένα gate είναι βραχυκυκλωμενο θα παραμείνει έτσι. Το πρόβλημα είναι στην σειριακή επικοινωνία από το μήνυμα που βλέπω. Η κεφαλη κάνει ρεσετ? Bumping. Και για σιγουριά αλλά αν και πολύ remote μέτρα τα ohm στην κεφαλη.
 

Pablo Sanchez

Retro Member
Comrade
Joined
Aug 31, 2017
Messages
125
Οκ, θα το βγάλω καλού κακού το 74LS14 και θα βάλω καινούριο και θα σας πω, το reset πως το κάνω ;
 

Pablo Sanchez

Retro Member
Comrade
Joined
Aug 31, 2017
Messages
125
Τελικά αντικατέστησα το 74LS14 και όλα είναι οκ τώρα, έκανα ένα reset με την εντολή:

Code:
OPEN 1,8,15,"I0":CLOSE 1

και η κεφαλή ανταποκρίθηκε και διάβασα μία παλαιά δισκέτα.

Ευχαριστώ τον @Pluto63 για την πολύτιμη βοήθειά του!
 

Attachments

  • IMG_20200229_131458.jpg
    IMG_20200229_131458.jpg
    1.1 MB · Views: 9
  • IMG_20200229_132603.jpg
    IMG_20200229_132603.jpg
    3 MB · Views: 10

dR_wH0

Solder Noob
Staff member
Comrade
Joined
Mar 24, 2012
Messages
5,854
Το piggyback στα LS δεν δουλεύει αν ένα gate είναι βραχυκυκλωμενο θα παραμείνει έτσι.

Χμμμ ενδιαφέρον δεν το ήξερα αυτό. Dully noted :>
 
Top